DocumentationDiscussions
DocumentationDiscussions

Discussions

Ask a Question

Entries in seq do not appear unless certain code is executed.

So I have recently plugged serilog into seq and I have been trying to get this working but have encountered a strange problem. I have injected an instance of ILogger into my code and this works fine for Console logs, but the seq logs appear to be blocked until other parts of the code have executed. For example, with the following 5 lines of code; 1. _ logger.LogInformation($"Processing user {user}",user.Email); 2. _logger.LogError($"Processing user {user}", user.Email) 3. _notifications.Clear(); 4. var domains = await _domainRepository.ListAsync(new ActiveDomainsForUser(user.Id, true)); 5 foreach (var domain in domains) If I put a breakpoint on line 3, the seq logs do not arrive. If I then step through to line 4, the seq logs do not arrive. If I then step through to line 5, the seq logs then arrive. It is as if there is some blocking going on that is released after the async repository call (which does not have an ILogger injected) and does nothing funky at all. I can reproduce this each and every time and regardless of how long I pause debugging, the logs always arrive very shortly after line 5 is executed. Suggestions would be appreciated.

Seq Web App Will not Run

Hi, I've installed Seq on a server in our environment. When attempting to load that via port 5314, the site can't be reached. I've also attempted loading it locally, while on the server i.e. http://localhost:5314 I ran the following command from the cmd prompt and it resulted in the text which follows: C:\ Seq run ──────────────────────────────────────── Seq ♦ Machine data, for humans. ─────────── © 2021 Datalust Pty Ltd ──── Running as server; press Ctrl+C to exit. [11:29:21 INF] Seq "2021.2.6459" running on OS "Microsoft Windows Server 2016 Standard" [11:29:21 INF] Seq detected 4293.890048 MB of RAM [11:29:21 INF] Opening event store at "C:\\ProgramData\\Seq\\Stream\\stream.flare" [11:29:21 INF] Opening metastore "C:\\ProgramData\\Seq\\Documents\\default.quince" [11:29:21 INF] Storage subsystem available [11:29:22 INF] Seq listening on ["http://localhost:5341/"] [11:30:22 INF] 1 more generation 2 garbage collection(s) occurred [11:34:22 INF] Metrics sampled I've opened the port on the firewall and am out of ideas. Any idea why Seq won't run on this server?

Private libraries built by BaGet cannot be downloaded in SEQ

SEQ runs in docker,I built a private library with BaGet, but I could not download the library through SEQ. An error was reported during the download process, and the error log is as follows: seq version:2021.2.6459 ``` [08:54:34 INF] Applying 0 retention policies [08:54:34 INF] Retention processing and compaction took 1.1208 ms; allocating 599998.8792 ms for indexing [08:54:34 INF] Beginning indexing [08:54:34 INF] Wrote 0 index sets in 6 ms [08:54:34 INF] Indexing took 6 ms; total iteration time was 7.525 ms [08:54:35 INF] Metrics sampled [08:54:36 INF] Updated "nugetfeed-36" [08:54:48 ERR] Unable to install package "Seq.App.Slack" vnull from "nugetfeed-36" System.ArgumentNullException: Value cannot be null. (Parameter 'value') at Newtonsoft.Json.Linq.Extensions.Value[T,U](IEnumerable`1 value) at Seq.Server.Features.Installation.Nuget.PackageRepositoryV3.FindPackageAsync(String packageId, SemVersion version) at Seq.Server.Features.Installation.AppPackageStore.GetOrInstallAsync(NuGetFeed feed, String packageId, String version, Boolean force) at Seq.Server.Features.Installation.AppPackageInstaller.DownloadAndInterrogateAsync(String nuGetFeedId, String packageId, String version, Boolean force) at Seq.Server.Features.Installation.AppPackageInstaller.InstallPackageAsync(String nuGetFeedId, String packageId, String version) at Seq.Server.Web.Api.AppsController.InstallPackage(String feedId, String packageId, String version) [08:59:35 INF] Metrics sampled ```

Azure SQL as as a Metastore

Hi, I'm currently experimenting with running Seq in an Azure Web App. And yes, I know it is not the recommended way and so on an so forth. I know the risks, so what I want to do is: - Use premium storage for the File Share as I've read that the problem with corruption is less prominent on that tier. - Use Azure SQL as described here: https://docs.datalust.co/docs/sql-server as a MetaStore. However, I find the documentation to be lacking (or I don't understand it correctly). Should the connection string always be "Initial Catalog=seq-local;Integrated Security=True"? I assume you don't need the database to be called seq-local - or do you? The value of SEQ_METASTORE_MSSQL_MSIRESOURCE - In what cases should this not be https://database.windows.net/? And lastly, how should you set up the Managed Identity? Can it not be a System Assigned Identity? I've tried giving it the SQL Server Contributor Role, I've tried setting it as admin of the database server, I've run the SQL-script shown in this article: https://docs.microsoft.com/en-us/azure/app-service/app-service-web-tutorial-connect-msi?tabs=windowsclient%2Cdotnetcore. Nothing works... So, some more details on this topic would be very much appriciated.

how to fetch missing records

is there a facility to use JOINS ?

Is there an exsisting opensource project to "scrape" and/or parse IIS and SqlServer logs and send them to Seq?

Before I reinvent something... Has anyone found a convenient way to "scrape" or parse IIS and SqlServer logs and send them to Seq?

sqq cant start

Hi I try to activate the SEQ through services but I get a message: "the seq service on local computer started and stopped some service stop automatically if they are not in use by other services or programs" What can I do ?

How reset admin password in docker?

I forget my admin password. I try use command: seq auth --basic -u admin -p 123456 seq: extra operand 'admin' Try 'seq --help' for more information. How reset my password in LINUX docker?

Seq windows service running listening domain, but, not accessible

Seq windows service running listening domain, but, not accessible. I tried run it from command line, and no errors. Everything working right. But, I can't access from browser. I just receive a message: This site can't be reached. I just restarted the server and seq is not working more. And yes, my DNS endpoints are correctly.

Post "LicenseText" from Powershell

I tried $params = @{"LicenseText"="Serial: XXX\nLicensed-To: XX........, "id"="license-server"}; Invoke-WebRequest -Uri http://localhost:5341/api/licenses/ -Method POST -Body ($params|ConvertTo-Json) -ContentType "application/json" And get 405 Method Not Allowed How do I build a request so that the server accepts the text of my license?