DocumentationDiscussions
DocumentationDiscussions

Discussions

Ask a Question
Back to All

Renewal request

Hello, We're software reseller from Moscow, Russia. Our customer is interested in renewal Sec Business, Serial: SDES-01-3586495 Licensed-To: AO «Kaspersky Lab» Licensed-Users: 15 Enduser is Kaspersky Lab Please give me price and delivery information. Thank you in advance, Mikhail Kapyrin Systems 21 / Prodmag.ru email:[email protected] tel:+74996494952 tg:@mkapyrin http://www.prodmag.ru

A mean(x) group by query doesnt work - error

If I run this: "SELECT mean(RTT) group by SubPacketType from stream" I get an error saying: "The query could not be executed. Syntax error (line 1, column 41): unexpected keyword `from`." But, if I check the docs they have an more or less identical example: https://docs.getseq.net/docs/aggregate-operators and the example there is: "select mean(ItemCount) group by ItemId from stream" Any ideas here? I wanted to upload a picture from the stream, but cant do it here when creating a post...

When searching (SELECT) for log rows, return clickable and "normal looking" rows?

Hey, if I run a query, like: SELECT RTT from stream WHERE RTT IS NOT NULL where RTT is a prop I created ("round trip time"), Id like the results to be returned and look as the "signal" list does (with tags, clickable so I can view the rest of the properties etc), bit instead i get a plain text-list that I cannot work with at all. Question is - can it be done, to get a "normal" looking list?

Seq not using all memory available

I read that by default, seq should be using 90% of the server available memory, but I cannot seem to pass 70%. I had a 8gb RAM server, increased it to 16Gb, but even after many hours, Seq won't use more than 71%. I even tried to setup seq on the command line to use 95% or so, but it remain on 70. Is there any reason for this?

Seq using large amount of memory on Windows

Seq seems to be using a large amount of memory on my Windows 10 machine. I'm using Seq version 4.2. Here is a screenshot of my Task Mangaer: https://i.imgur.com/P6GTHuk.png. This screenshot was taken right after a reboot.

Alias the grouped column

Is it possible to alias the grouped column in a SQL query? Its convenient that the grouped column is automatically included in the tabular output, but I dont see how we can rename it. Queries that group on expressions could benefit from an alias, for example: select count(*) as total from stream where IndexOf(UriStem, /\.[A-z]{2,4}$/) <> -1 group by SubString(UriStem, IndexOf(UriStem, /\.[A-z]{2,4}$/), 4) order by total desc

SEQ Http API

I've got the GitHub examples working - very nice.... and I can obtain the basic events - but how do I get the event Document with the full message...?

How to install with Professional License?

Hi, I have received the SEQ "Professional License", how would I install this manually? Also I am interested in installing it via powershell, I've seen the previous posts "Provide license file during installing Seq using msi", and do not have a clear understanding of Step 4 in the reply: " This can be done using Powershell after the Seq service is installed and started, so: Install the MSI (assuming that you have automated this part) Start the service, using seq.exe start It may be necessary to wait a few seconds for the service to start up POST the license text to /api/licenses/license-server using a JSON body like: {"LicenseText":"Serial..."} "

Alert error

Hi, I'm getting this error when I click over plus icon to add a new alert: vendor-1500420102219.min.js:2 TypeError: Cannot read property 'push' of undefined at e.value (seq-ui2-1500420102219.min.js:81) at e.value (seq-ui2-1500420102219.min.js:129) at fn (eval at compile (vendor-1500420102219.min.js:4), <anonymous>:4:194) at i (vendor-1500420102219.min.js:5) at p.$eval (vendor-1500420102219.min.js:3) at p.$apply (vendor-1500420102219.min.js:3) at HTMLButtonElement.<anonymous> (vendor-1500420102219.min.js:5) at Jt (vendor-1500420102219.min.js:1) at HTMLButtonElement.n (vendor-1500420102219.min.js:1)

Browser back button changes URL but UI doesn't update

On the main screen: http://localhost:5341/#/events I type "something" and hit enter, URL changes to http://localhost:5341/#/events?filter=something and the UI updates to show the correct log entries. I hit the back button and the URL changes back to http://localhost:5341/#/events but the UI doesn't update at all and "something" still shows in the search box. Running Seq 4.2.476 on 64bit Windows 10 Enterprise (build 16299) using 64bit Chrome 63.0.3239.132.

Custom Domain Name not Working

Hello, I'm trying Seq but I have problem about custom domain. I created windows server on Amazon EC2 and I installed Seq with http://seq.mydomain.com/ After I forwarded seq.mydomain.com to server IP on Amazon Route53. Now, when I ping subdomain, I'm getting corret server IP but I can not get respond from respond from seq.domainname.com. Best.

Securing Seq

We're evaluating Seq for use in AWS with our app. We have no interest in active directory or azure, so how would one secure Seq given the api and admin ui appear to be combined?

Provide license file during installing Seq using msi

How can we provide licensing details to seq installer during installtion itself without manual intervention like using Powershell/ command line?

one license for multiple instance

Hello ,can i use seq license in multiple instance , i want buy seq for my product and each product publish separately for customers , can i use one license for all of them ?

License agreement

Hi Where can we find a copy of your license agreement and or your usage Terms and Conditions? Thanks

Selected Time Interval on Dashboard

Is there a way to know the selected time interval chosen by the user in the dashboard window? i would like to use this time period in a calculation. Using version 4.1.17. Thanks in advance.

Cannot see settings menu in header

Hi there, I cannot see the settings menu in the header in our Seq install. My guess would be that my user account does not have admin privileges (despite the username being "admin"). The person who set this up is no longer with the company. Is there anyway I can elevate my account to admin privileges? I have access to the Seq command line on the server. I've tried resetting his password using "seq unlock -u username -p password" but I get the error "Could not reset the password: Cannot access file, the file is locked or in use". However, I am just guessing what his username is. Any help would be greatly appreciated, Josh

Serverless Install On Azure

Is there any way to install SEQ on an Azure Web App instance or some other serverless instance on Azure?

How to enforce query timeout (for any query)?

Hi, Is there an option to enforce query timeout for any query against the stored events? I know there is a setting in user preferences, but that only affects SQL queries. I would also like regular text based searches and signals to time out. The problem I would like to solve is that some of the users start a long running query that has 0 results, so basically Seq has to go through all the stored events (which gets slow once they need to be read off the disk). Then the users forget to cancel the query so it runs until completion, which can take several minutes, using a lot of server's resources.

Freetext search over context properties?

Is it possible to freetext search over object properties if they are not part of @Message? For example: `var myObject = new MyObject { Id = 909090, Name = "ux909090"}; Serilog.Log.ForContext("MyObject", myObject).Information("Hello World");` We could not find a way to search for the Id without using MyObject.Id =909090. When using a text query like “909090” is it only @Message that is evaluated? Why not @Document as well?