Seq Documentation and Support

Welcome to the Seq documentation hub. You'll find comprehensive guides and documentation to help you start working with Seq as quickly as possible, as well as support if you get stuck. Let's jump right in!

Get Started    


Ask A Question

Seq is unavailable. Failed to initialize storage: Failed to open environment at path /data/Documents/documents.lmdb

I run seq docker container using this command: docker run -d --restart unless-stopped --name seq -e ACCEPT_EULA=Y -v //d/Logs/Seq:/data -p 8081:80 datalust/seq:latest Docker container is up and running. But in logs I found this {"@t":"2020-07-03T18:34:31.1510983Z","@mt":"Seq {SeqVersion} running on OS {OSCaption}","SeqVersion":"2020.1.4235","OSCaption":"Linux 4.14.154-boot2docker #1 SMP Thu Nov 14 19:19:08 UTC 2019","SourceContext":"Seq.Server.Features.Diagnostics.EnvironmentInformationWriter"} {"@t":"2020-07-03T18:34:31.2140954Z","@mt":"Seq detected {TotalRAM} MB of RAM","TotalRAM":1037.53728,"SourceContext":"Seq.Server.Features.Diagnostics.EnvironmentInformationWriter"} {"@t":"2020-07-03T18:34:31.7707651Z","@mt":"Seq listening on {ListenUris}","ListenUris":["http://localhost/","http://localhost:5341/"]} {"@t":"2020-07-03T18:34:31.8006169Z","@mt":"Opening event store at {StreamPath}","StreamPath":"/data/Stream/stream.flare","SourceContext":"Flare.Cluster.StorageNodeCoordinator"} {"@t":"2020-07-03T18:34:31.8511073Z","@mt":"Opening metastore {MetastorePath}","MetastorePath":"/data/Documents/documents.lmdb","SourceContext":"Quince.Storage.Lmdb.LmdbDocumentStore"} {"@t":"2020-07-03T18:34:31.8713447Z","@mt":"Closing event store","SourceContext":"Flare.Cluster.StorageNodeCoordinator"} {"@t":"2020-07-03T18:34:31.8745417Z","@mt":"Uncaught exception from worker {WorkDescription} ({WorkId})","@l":"Error","@x":"Autofac.Core.DependencyResolutionException: An exception was thrown while activating Seq.Server.Web.Authentication.SeqOidcAuthenticationScheme -> Seq.Server.Features.Settings.SystemSettings -> λ:Quince.DocumentStore -> λ:Seq.Server.StorageSubsystem.\n ---> LightningDB 0: Failed to open environment at path /data/Documents/documents.lmdb\n --- End of inner exception stack trace ---\n at Autofac.Core.Resolving.InstanceLookup.Activate(IEnumerable`1 parameters, Object& decoratorTarget)\n at Autofac.Core.Resolving.InstanceLookup.<>c__DisplayClass6_0.<Execute>b__0()\n at Autofac.Core.Lifetime.LifetimeScope.GetOrCreateAndShare(Guid id, Func`1 creator)\n at Autofac.Core.Resolving.InstanceLookup.Execute()\n at Autofac.Core.Resolving.ResolveOperation.GetOrCreateInstance(ISharingLifetimeScope currentOperationScope, IComponentRegistration registration, IEnumerable`1 parameters)\n at Autofac.Core.Resolving.ResolveOperation.ResolveComponent(IComponentRegistration registration, IEnumerable`1 parameters)\n at Autofac.Core.Resolving.ResolveOperation.Execute(IComponentRegistration registration, IEnumerable`1 parameters)\n at Autofac.Core.Lifetime.LifetimeScope.ResolveComponent(IComponentRegistration registration, IEnumerable`1 parameters)\n at Autofac.Features.LazyDependencies.LazyRegistrationSource.<>c__DisplayClass5_1`1.<CreateLazyRegistration>b__1()\n at System.Lazy`1.ViaFactory(LazyThreadSafetyMode mode)\n at System.Lazy`1.ExecutionAndPublication(LazyHelper executionAndPublication, Boolean useDefaultConstructor)\n at System.Lazy`1.CreateValue()\n at System.Lazy`1.get_Value()\n at Seq.Server.ServiceProcess.SystemServices.Start(CancellationToken& cancel)\n at Seq.Server.ServiceProcess.ServerService.<Start>b__8_0(CancellationToken cancel)\n at Flare.Workers.WorkerPool.<>c__DisplayClass6_0.<Run>b__0(CancellationToken ct)\n at Flare.Workers.WorkerPool.<>c__DisplayClass7_0`1.<Run>g__DoWork|0()","WorkDescription":"Start background processes","WorkId":"3507f033-2175-4170-9ee8-2ef0fa0db8c9","SourceContext":"Flare.Workers.WorkerPool"} I am using docker toolbox for running the container. Once the container started, I could see the files generated on my local system, but got stuck with this error.

Posted by annamalai about a year ago


Is required IIS on Windows Server 2012 R2 to run Seq ?

Hello, I have a win server 2012, without IIS installed. The web UI of SEQ is running fine at 5341 port. Using this code and this settings file I cannot write any message to log, the server response is always : requests.exceptions.HTTPError: 403 Client Error: URLBlocked for url: http://localhost:5341/api/events/raw I tried to set, or IP, or localhost, always the same issue. I have set permission to IIS_IUSR to Seq folder. Any suggest ? Thanks ----------------------------- import seqlog import logging import yaml seqlog.configure_from_file('./logging-config.yml') logger = logging.getLogger()'This is the root logger****') # Use another logger another_logger = logging.getLogger('another_logger') # Indexer-style"Hello, %s!", "World****") # Message template style"Hello, {name}!", name="World****") # Logging to another logger'This is another logger****') --------------------------------- logging-config.yml: # This is the Python logging schema version (currently, only the value 1 is supported here). version: 1 # Configure logging from scratch. disable_existing_loggers: True # Configure the root logger to use Seq root: class: seqlog.structured_logging.StructuredRootLogger level: INFO handlers: - seq - console loggers: # A non-root logger. another_logger: class: seqlog.structured_logging.StructuredLogger propagate: False level: INFO handlers: - seq - console handlers: # Log to STDOUT console: class: seqlog.structured_logging.ConsoleStructuredLogHandler formatter: seq # Log to Seq seq: class: seqlog.structured_logging.SeqLogHandler formatter: seq auto_flush_timeout: 3000 # milliseconds # Seq-specific settings (add any others you need, they're just kwargs for SeqLogHandler's constructor). server_url: 'http://localhost:5341/' api_key: 'my aAPI key' formatters: seq: style: '{'

Posted by Claudio Barca about a year ago


Querying Events by Date/Time directly via the REST API

Hello Support, During the last week I've been doing some testing with the API. I started off with using the NuGet package and had some challenges but In the end I had better success just writing my own HTTP Client in .NET Core 3.1 and have been sending my own GET requests directly to the Seq Api. I'm using Postman and my own Swagger UI for testing. I'm just a little stuck however while testing a query through the Api using a date&time based search. In the Seq UI via the browser, I used the 'datetime picker' and ran a simple search for events received just from the beginning of today (the results produced just one row/event which is correct as I'd only sent one log event to the Seq server today) http://localhost:5341/#/events?from=2020-06-28T00:00:00.000Z (URL Query string from the Seq Browser UI) However when I run a similar a query through Postman to the Api, I get a lot more events coming back as far as yesterday. Not sure why this is happening? http://localhost:5341/api/events?from=2020-06-28T00:00:00.000Z (GET request used in Postman) I have reviewed the documentation but I couldn't find any examples that covered queries directly to the API. I'd be grateful if you could provide a couple of URI examples. The most common types of search criteria I'm wanting to figure is as follows: > GET events within last hour or day or X hours or X days. > GET events between a start and end period using DateTime filters. > Use paging via the Api to prevent server melt down when there are lots of rows to retrieve from a large query i.e. being able to page through the results bit by bit. Once I understand how to query using time/date through the Rest Api then I should hopefully be able to move forward. I'm already using the SQL Queries via the API (I had to derive my own logic to build up the URI string correctly but this part is working OK) Thanks in advance.

Posted by OLIVER BENTLEY about a year ago