DocumentationDiscussions
DocumentationDiscussions

Discussions

Ask a Question

Windows Service Account - gMSA supported

For a Windows deployment, could you advise if SEQ supports the use of Group Managed Service Accounts (gMSA's) for the SEQ Service Account. If so, at the point that the Service Account is required in the installation, will SEQ recognise that the password will not be required? Many thanks

Built-In properties like Message Properties applied to log events are not being read inside Seq emailplus App.

I am not able to read build in properties in HTML template. Any idea on how to use it? I have tried {{$Message}} ,{{@mt}} in HTML and nothing works.Everything shows it as empty. Cant we not read the properties of the log event in HTML before sending it via Email? If not we really Need this feature

flooding behavior

I had a situation where seq was being flooded by a very short interval retry loop; We could tell by disk space consumption, but the events from the ui seemed normal, so we had no way of telling which service was causing the issue. When we eventually figured out which service it was and turned it off, all of those messages showed up. Obviously someone made a pretty big mistake to begin with, but it would have been a lot more helpful to have been able to see those events, is there some reason that it behaved this way? I'm assuming seq was waiting for a break in ingest to process but that break never came?

No data shown if Table style is selected on a dashboard.

I have following query: select Last(errorCount) as Errors, Last(warningCount) as Warnings, Last(successCount) as Successes, Last(errorCount)+Last(warningCount)+Last(successCount) as Total from stream where Has(successCount) It shows expected data in the events window. When added to a dashboard, it shows data if Bar, Line, or Point style is selected. No data are displayed if I select Table style (which is my preferred choice since I'm interested in last values only). Under DefTools I see no errors and following call to api /api/data?q=select%20Last%28errorCount%29%20as%20Errors%2C%20Last%28warningCount%29%20as%20Warnings%2C%20Last%28successCount%29%20as%20Successes%2C%20Last%28errorCount%29%2BLast%28warningCount%29%2BLast%28successCount%29%20as%20Total%0D%0Afrom%20stream%20%0D%0Awhere%20%28%40Timestamp%20>%3D%20DateTime%28%272021-03-14T12%3A30%3A00.000Z%27%29%29%0D%0A%20%20and%20%28%40Timestamp%20<%20DateTime%28%272021-03-16T12%3A59%3A50.583Z%27%29%29%0D%0A%20%20and%20%28Has%28successCount%29%29%0D%0Afor%20window%2830m%29%0D%0A&signal=signal-279&timeoutMS=60000 returns this json: {"Columns":["Errors","Warnings","Successes","Total"],"Rows":[[262,0,0,262]],"Statistics":{"ScannedEventCount":2495,"MatchingEventCount":0,"UncachedSegmentsScanned":false,"ElapsedMilliseconds":1.9800000000000002}}

Change Y-axis bounds

Hi! I have a chart in which I'm tracking CO2 PPM. I am wondering if there is a way in which I can rescale the Y-axis so that my points aren't falling out of range. See link for a picture. Thanks! https://i.ibb.co/zPWKGqV/image.png

Picking the same time for from and to results in no records...

Not sure if this intended or a bug but in my web app I set a link to a message in on our server and by setting the from and to query parameters. When these are the same I get no results e.g. &from=2021-03-04%2000:15:04Z&to=2021-03-04%2000:15:04Z From the API I assumed from was inclusive and to exclusive so that I'd get the one record.

Seq.API : How do I change the Connection.Data.QueryAsync time out?

I'm trying use the API and I keep getting the following exception. I've tried supplying my own cancellation token, I've tried a retry pattern. No luck. System.Threading.Tasks.TaskCanceledException: The request was canceled due to the configured HttpClient.Timeout of 100 seconds elapsing. ---> System.TimeoutException: The operation was canceled. ---> System.Threading.Tasks.TaskCanceledException: The operation was canceled. ---> System.IO.IOException: Unable to read data from the transport connection: The I/O operation has been aborted because of either a thread exit or an application request.. ---> System.Net.Sockets.SocketException (995): The I/O operation has been aborted because of either a thread exit or an application request. --- End of inner exception stack trace --- at System.Net.Sockets.Socket.AwaitableSocketAsyncEventArgs.ThrowException(SocketError error, CancellationToken cancellationToken) at System.Net.Sockets.Socket.AwaitableSocketAsyncEventArgs.GetResult(Int16 token) at System.Net.Http.HttpConnection.FillAsync(Boolean async) at System.Net.Http.HttpConnection.ReadNextResponseHeaderLineAsync(Boolean async, Boolean foldedHeadersAllowed) at System.Net.Http.HttpConnection.SendAsyncCore(HttpRequestMessage request, Boolean async, CancellationToken cancellationToken) --- End of inner exception stack trace --- at System.Net.Http.HttpConnection.SendAsyncCore(HttpRequestMessage request, Boolean async, CancellationToken cancellationToken) at System.Net.Http.HttpConnectionPool.SendWithRetryAsync(HttpRequestMessage request, Boolean async, Boolean doRequestAuth, CancellationToken cancellationToken) at System.Net.Http.RedirectHandler.SendAsync(HttpRequestMessage request, Boolean async, CancellationToken cancellationToken) at System.Net.Http.HttpClient.SendAsyncCore(HttpRequestMessage request, HttpCompletionOption completionOption, Boolean async, Boolean emitTelemetryStartStop, CancellationToken cancellationToken) --- End of inner exception stack trace --- --- End of inner exception stack trace --- at System.Net.Http.HttpClient.SendAsyncCore(HttpRequestMessage request, HttpCompletionOption completionOption, Boolean async, Boolean emitTelemetryStartStop, CancellationToken cancellationToken) at Seq.Api.Client.SeqApiClient.HttpSendAsync(HttpRequestMessage request, CancellationToken cancellationToken) at Seq.Api.Client.SeqApiClient.PostAsync[TEntity,TResponse](ILinked entity, String link, TEntity content, IDictionary`2 parameters, CancellationToken cancellationToken) at Seq.Api.ResourceGroups.ApiResourceGroup.GroupPostAsync[TEntity,TResponse](String link, TEntity content, IDictionary`2 parameters, CancellationToken cancellationToken) at Seq.Api.ResourceGroups.DataResourceGroup.QueryAsync(String query, Nullable`1 rangeStartUtc, Nullable`1 rangeEndUtc, SignalExpressionPart signal, SignalEntity unsavedSignal, Nullable`1 timeout, CancellationToken cancellationToken)
ANSWERED

Install Apps via an Unattended Installation

Is it possible to install a Seq App via the command-line?

no ui displayed

Anyone has this issue? On local machine, works fine. On corporate laptop I see a lightshow colours switching but no UI. I am guessing protection software blocking the ip:port numbers and I have tried a bunch of those.

Different API Keys using GELF

I'm sending logs to Seq from Golang apps by way of GELF and go-gelf (https://docs.datalust.co/docs/using-go). Is there any way to set different API keys from the client side for Go / GELF like can be done from the .NET side using Serilog and similar? The only way I see is to set an API key is on the datalust/seq-input-gelf container (https://docs.datalust.co/docs/using-gelf) which currently limits me to 1. Technically I suppose multiple of those could be added with different ports and API keys for different apps but that seems heavy handed. Ideally there'd be a way to set when each app initializes a UDP/TCP writer and having a special extra field in the payload that represents the API key?

Problem with Installation of App via Private Nuget Stream

Hi, I am evaluating Seq and have a Problem with the App Installation: Error: Could not install app 'Seq.Server.Features.Installation.Nuget.PackageRepositoryV2.Xml' does not contain a definition for 'IconUrl' This stops my installation. I am trying to install Seq.App.EmailPlus. Maybe this could just be a warning? On another test instance i managed to install the same package yesterday...? Thanks, Henning

Email Dashboards

Hi, Is there a plan to email/post dashboard contents at any point? We'd really like to be able to configure a dashboard and have an email delivered containing the charts daily/weekly/monthly for the dashboard contents by day/week/month to give us sight of stats without logging on. Having the ingestion stats would also be a useful part to add to this too.

Query of JSON property doesn't find anything

I have a field called Data, which contains JSON data that looks like this: [{Key: 'direction', Value: […], _typeTag: 'KeyValuePair`2'}, {Key: 'username', Vale: […], _typeTag: 'KeyValuePair`2'}, {Key: 'composed_at', Value: […], _typeTag: 'KeyValuePair`2'}, {Key: 'message_type', Value: […], _typeTag: 'KeyValuePair`2'}, {Key: 'workflow_action', Value: […], _typeTag: 'KeyValuePair`2'}, {Key: 'platform_received_at', Value: […], _typeTag: 'KeyValuePair`2'}, {Key: 'form_data[CurrentLocation.latitude]', Value: […], _typeTag: 'KeyValuePair`2'}, {Key: 'form_data[CurrentLocation.longitude]', Value: […], _typeTag: 'KeyValuePair`2'}, {Key: 'form_data[HPV-Requirement-Check]', Value: […], _typeTag: 'KeyValuePair`2'}, {Key: 'form_data[ShowCustomerRules]', Value: […], _typeTag: 'KeyValuePair`2'}, {Key: 'form_data[ShowHVP]', Value: […], _typeTag: 'KeyValuePair`2'}, {Key: 'form_code', Value: […], _typeTag: 'KeyValuePair`2'}] It seems to me that this query should be able to find that JSON message. SELECT Message FROM stream WHERE Message.Data.FormCode = '01' But nothing is ever returned. My goal is to find all instances of FormCode = '01' when another field - form_data['LOAD_NUMBER'] is not present.

Couldnot log to remote server!

Hi, I am trying to log to remote server but nomatter what I do couldnot see any log in seq server. Can you help please

Container does not run

Hi! Help me please docker run --name seq -d --restart unless-stopped -e ACCEPT_EULA=Y -p 5341:80 datalust/seq:latest Unable to find image 'datalust/seq:latest' locally latest: Pulling from datalust/seq f22ccc0b8772: Pull complete blablabla 479589f337aa: Pull complete Digest: sha256:b33cb3528d013db633a2b0823f6935024df2539e76dba767cd9366f1007207f0 Status: Downloaded newer image for datalust/seq:latest 8f5245edaff1c54f622e58f9aa3548496046ce5963fa70ff74e737e2ac00dbd5 docker: Error response from daemon: Ports are not available: listen tcp 0.0.0.0:5341: bind: An attempt was made to access a socket in a way forbidden by its access permissions.

Problem installing using docker container

Hi all. I am trying to use seq in ubuntu(not snap actually installed normally). Here is the command I am using. sudo docker run --name seq -d --restart unless-stopped -e ACCEPT_EULA=Y -e SEQ_FIRSTRUN_ADMINPASSWORDHASH="$PH" -v ~/Docker/Seq/Data/Dev/data -p 82:80 -p 5341:5341 datalust/seq The container starts, and image is downloaded, but I can't connect to it, or curl -i Get -x localhost:82 it. I get this in the logs ──────────────────────────────────────── Seq ♦ Machine data, for humans. ─────────── © 2020 Datalust Pty Ltd ──── Running as server; press Ctrl+C to exit. [22:09:57 INF] Seq "2020.5.5163" running on OS "Linux 5.8.0-38-generic #43-Ubuntu SMP Tue Jan 12 12:42:13 UTC 2021" [22:09:57 INF] Seq detected 8344.461312 MB of RAM [22:09:58 INF] Seq listening on ["http://localhost/", "http://localhost:5341/"] [22:09:58 INF] Opening event store at "/data/Stream/stream.flare" [22:09:58 INF] Opening metastore "/data/Documents/documents.lmdb" [22:09:58 INF] Initializing a new metastore [22:09:58 INF] Enabling username/password authentication, and using the supplied default admin password or hash [22:09:58 INF] Closing metastore [22:09:58 INF] Closing event store [22:09:58 ERR] Uncaught exception from worker "Start background processes" ("c3463719-ef8e-49f0-990b-8f23d7315396") Autofac.Core.DependencyResolutionException: An exception was thrown while activating Seq.Server.Web.Authentication.SeqOidcAuthenticationScheme -> Seq.Server.Features.Settings.SystemSettings -> λ:Quince.DocumentStore -> λ:Seq.Server.StorageSubsystem. ---> System.IndexOutOfRangeException: Index was outside the bounds of the array. at Seq.Server.Config.Encoding.Base64SaltedHashEncoding.FromBase64(String base64) at Seq.Server.Data.Users.Migrations.CreateAdminUser.Apply(DocumentSession session) at Quince.Storage.Lmdb.LmdbDocumentStore.Migrate(IEnumerable`1 migrations) at Seq.Server.StorageSubsystem.Initialize(IComponentContext ctx, SeqConfig config, String instanceName, String storageRootPath, String nodeStateFilePath, String streamPath, String documentsPath) at Seq.Server.SeqServerModule.<Load>b__14_7(IComponentContext c) at Autofac.RegistrationExtensions.<>c__DisplayClass4_0`1.<Register>b__0(IComponentContext c, IEnumerable`1 p) at Autofac.Builder.RegistrationBuilder.<>c__DisplayClass0_0`1.<ForDelegate>b__0(IComponentContext c, IEnumerable`1 p) at Autofac.Core.Activators.Delegate.DelegateActivator.ActivateInstance(IComponentContext context, IEnumerable`1 parameters) at Autofac.Core.Resolving.InstanceLookup.CreateInstance(IEnumerable`1 parameters) --- End of inner exception stack trace --- at Autofac.Core.Resolving.InstanceLookup.CreateInstance(IEnumerable`1 parameters) at Autofac.Core.Resolving.InstanceLookup.<Execute>b__8_0() at Autofac.Core.Lifetime.LifetimeScope.CreateSharedInstance(Guid id, Func`1 creator) at Autofac.Core.Lifetime.LifetimeScope.CreateSharedInstance(Guid primaryId, Nullable`1 qualifyingId, Func`1 creator) at Autofac.Core.Resolving.InstanceLookup.Execute() at Autofac.Core.Resolving.ResolveOperation.GetOrCreateInstance(ISharingLifetimeScope currentOperationScope, ResolveRequest request) at Autofac.Core.Resolving.ResolveOperation.ResolveComponent(ResolveRequest request) at Autofac.Core.Resolving.ResolveOperation.Execute(ResolveRequest request) at Autofac.Core.Lifetime.LifetimeScope.ResolveComponent(ResolveRequest request) at Autofac.Features.LazyDependencies.LazyRegistrationSource.<>c__DisplayClass5_1`1.<CreateLazyRegistration>b__1() at System.Lazy`1.ViaFactory(LazyThreadSafetyMode mode) at System.Lazy`1.ExecutionAndPublication(LazyHelper executionAndPublication, Boolean useDefaultConstructor) at System.Lazy`1.CreateValue() at System.Lazy`1.get_Value() at Seq.Server.ServiceProcess.SystemServices.Start(CancellationToken& cancel) at Seq.Server.ServiceProcess.ServerService.<Start>b__8_0(CancellationToken cancel) at Flare.Workers.WorkerPool.<>c__DisplayClass6_0.<Run>b__0(CancellationToken ct) at Flare.Workers.WorkerPool.<>c__DisplayClass7_0`1.<Run>g__DoWork|0() if I use just 80:80 I can access it from lan, but once I change it to 82:80 I can only get it from localhost

Winforms

Hi is there a core WinForms sample lying about.

Dynamic Dashboard

Hello , We can prepare query and than show with dashboard. All querys are where conditions static. Can I prepare query with dynamic input value? Exam : I entry Customer Number on dashboard and than run query according my customer number? Customer Number is simular/as variable. Thanks your answers.

GDPR | PCI Compliance

HI. In my previous company, I was using seq all the time and I was really happy with it. My current company is a lot more restrictive with what we can log or not. Personal data, and payment data are an important concern for us. I was wondering if there is any way we could in a centralized way control and sanitise some of that data.

HIPAA Compliance

Hello, Would SEQ be considered HIPAA compliant? Thanks, Stephen